Installation issues

openHAB for Qbus

Moderators: marc, Nico, Koen, Maarten

Message
Author
Jeroenvdd
Posts: 18
Joined: Sat Sep 21, 2019 12:16 am
Contact:

Re: Qbus on openHAB

#1 Post by Jeroenvdd » Mon Sep 23, 2019 12:30 pm

In de manual kom je op een bepaald punt op 'staat niet online je kan het downloaden op onze server'
waar exact vind ik die?

EDIT: krijg wel de melding
'loging in as openhab
failed to get the session'

er zal nog iets mis zijn:

miss tips voor de manual
zet de commands los en niet de paste van de cli :)
Last edited by Jeroenvdd on Mon Sep 23, 2019 12:58 pm, edited 1 time in total.

User avatar
Koen
Site Admin
Posts: 101
Joined: Wed Aug 29, 2018 1:26 pm
Location: Belgium
Contact:

Re: Qbus on openHAB

#2 Post by Koen » Mon Sep 23, 2019 12:53 pm

@jeroen: Probeer eens het commando 'sudo service openhab2 restart' in te voeren, het lijkt erop dat openHAB nog niet werd gestart.
PS hier kan u de handleiding in word document terugvinden, maakt het copy and paste verhaal iets toegankelijker.
You do not have the required permissions to view the files attached to this post.

Jeroenvdd
Posts: 18
Joined: Sat Sep 21, 2019 12:16 am
Contact:

Re: Qbus on openHAB

#3 Post by Jeroenvdd » Mon Sep 23, 2019 2:54 pm

Staat de qbus plugin ergens op een share?

User avatar
Koen
Site Admin
Posts: 101
Joined: Wed Aug 29, 2018 1:26 pm
Location: Belgium
Contact:

Re: Qbus on openHAB

#4 Post by Koen » Mon Sep 23, 2019 3:02 pm

De plugin staat op gitgub en wordt mee gekopieerd naar de map QbusOpenHab/JAR

Jeroenvdd
Posts: 18
Joined: Sat Sep 21, 2019 12:16 am
Contact:

Re: Qbus on openHAB

#5 Post by Jeroenvdd » Mon Sep 23, 2019 3:08 pm

Dan moet ik even los kijken
ik heb hier openhab al draaien op mijn synology,
werkt goed maar ga eens moeten kijken hoe ik de plugin kan uploaden / gson kan gebruiken

User avatar
Koen
Site Admin
Posts: 101
Joined: Wed Aug 29, 2018 1:26 pm
Location: Belgium
Contact:

Re: Qbus on openHAB

#6 Post by Koen » Mon Sep 23, 2019 3:15 pm

Hier is de link naar github :
https://github.com/QbusKoen/QbusOpenHab

Daar kan je de JAR file downloaden.

Gson zal je moeten updaten via de openHAB cli zoals beschreven in de handleiding.

User avatar
Koen
Site Admin
Posts: 101
Joined: Wed Aug 29, 2018 1:26 pm
Location: Belgium
Contact:

Installation issues

#7 Post by Koen » Mon Sep 23, 2019 8:27 pm

Her you can get help when the installation of openHAB or required software isn't comming along as it should.

Jeroenvdd
Posts: 18
Joined: Sat Sep 21, 2019 12:16 am
Contact:

Re: Installation issues

#8 Post by Jeroenvdd » Tue Sep 24, 2019 3:28 pm

ok even toch snel om pi geweest ipv vm / synology

heb alles ingesteld en openhabian draait ik zie ook een binding staan,

eenige vreemde is nog
na punt 1.14 do ik een reboot,
ik wacht en kan terug op 8080

maar bij cat bootlog.log krijg ik gewoon melding no such file or directory..

als ik de logs bekijk zie ik ook volgende

Unhandled Exception:
System.Net.Sockets.SocketException (0x80004005): Connection refused
at System.Net.Sockets.TcpClient.Connect (System.String hostname, System.Int32 port) [0x001fe] in <a9a08e39ba304bd0a84c49bd158dfc02>:0
at QbusClient.Module1.Connect2Server () [0x00000] in <3670908380d3431e9dd5b587 440f137f>:0
at QbusClient.Module1.Main () [0x00016] in <3670908380d3431e9dd5b587440f137f>: 0
[ERROR] FATAL UNHANDLED EXCEPTION: System.Net.Sockets.SocketException (0x8000400 5): Connection refused
at System.Net.Sockets.TcpClient.Connect (System.String hostname, System.Int32 port) [0x001fe] in <a9a08e39ba304bd0a84c49bd158dfc02>:0
at QbusClient.Module1.Connect2Server () [0x00000] in <3670908380d3431e9dd5b587 440f137f>:0
at QbusClient.Module1.Main () [0x00016] in <3670908380d3431e9dd5b587440f137f>:

--------------------------------------------------------------------------------------------------

Wat ik wel zie als 'verschil' in die startclient.sh staat er bij mij


mono QbusClient.exe 192.168.0.22 qbus qbus 123456 &
#mono ConsoleApp1.exe 192.168.0.22 qbus qbus 123456 &

in jullie handleiding staat consoleapp1.exe niet in comment en niets van qbusclient..
in de folder zie ik wel enkel die qbusclient staan dus denk dat dat wel goed is

de gegevens komen toch overeen met wat ik hier gebruik he:
creds.PNG
You do not have the required permissions to view the files attached to this post.

Jeroenvdd
Posts: 18
Joined: Sat Sep 21, 2019 12:16 am
Contact:

Re: Installation issues

#9 Post by Jeroenvdd » Tue Sep 24, 2019 5:33 pm

Voor het nu via mono ook nog eens manueel uit (heb username en paswoord ook ff op admin admin gezet)


[16:24:06] openhabian@openhab:~/QbusOpenHab/QbusClient$ mono QbusClient.exe 192.168.0.22 admin admin xxxxx &
[1] 4018
[17:30:49] openhabian@openhab:~/QbusOpenHab/QbusClient$
Unhandled Exception:
System.Net.Sockets.SocketException (0x80004005): Connection refused
at System.Net.Sockets.TcpClient.Connect (System.String hostname, System.Int32 port) [0x001fe] in <a9a08e39ba304bd0a84c49bd158dfc02>:0
at QbusClient.Module1.Connect2Server () [0x00000] in <3670908380d3431e9dd5b587440f137f>:0
at QbusClient.Module1.Main () [0x00016] in <3670908380d3431e9dd5b587440f137f>:0
[ERROR] FATAL UNHANDLED EXCEPTION: System.Net.Sockets.SocketException (0x80004005): Connection refused
at System.Net.Sockets.TcpClient.Connect (System.String hostname, System.Int32 port) [0x001fe] in <a9a08e39ba304bd0a84c49bd158dfc02>:0
at QbusClient.Module1.Connect2Server () [0x00000] in <3670908380d3431e9dd5b587440f137f>:0
at QbusClient.Module1.Main () [0x00016] in <3670908380d3431e9dd5b587440f137f>:0

Vanuit CLI pingen werkt ook en aanmelden op EQOweb met admin en admin via 8444 lukt ook perfect

User avatar
Koen
Site Admin
Posts: 101
Joined: Wed Aug 29, 2018 1:26 pm
Location: Belgium
Contact:

Re: Installation issues

#10 Post by Koen » Tue Sep 24, 2019 6:30 pm

System.Net.Sockets.SocketException (0x80004005): Connection refused

mono QbusClient.exe 192.168.0.22 qbus qbus 123456 &
Deze regel klopt niet volgens uw instellingen qbus qbus is de login en het wachtwoord, 123456 is het serienr van uw controller.
Dus voor u moet dit zijn
mono QbusClient.exe 192.168.0.22 admin admin 00????&


Deze foutmelding moet je wegkrijgen. Is je System Manager nog verbonden met de controller? Is je controller al geactiveerd voor de DLL of EQOmmand?
activated controller.jpg
You do not have the required permissions to view the files attached to this post.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests